3

After the latest OTA update my Nexus 9 boots forever. If I turn it off and then turn it on, it shows this

and then it boots forever (green, red, blue, yellow circles, squares, circle slices move forever). I tried rebooting it a few times and even tried going into recovery -> hboot -> factory reset. Nothing changed. My Nexus 9 was not rooted and doesn't have a custom recovery.

Is it clear from this information what is wrong with my tablet? Can I unbrick it by flashing a stock ROM using adb or something?

  • Some users reported that side-loading the OTA update solved the problem for them? You would need to find an appropriate OTA update file and side-load it in recovery mode using adb. – Firelord May 9 '16 at 22:32
  • @Firelord Do those OTA updates require that I have an exact Android version installed already? – CrabMan May 9 '16 at 23:49
  • Yes, those updates do. – Firelord May 9 '16 at 23:54
  • I've got the exact same problem last night ;-( there's another similar post in progress too android.stackexchange.com/questions/144456/… – Alécio Carvalho May 10 '16 at 10:55
4

I've got the same problem on a recent OTA update on my Nexus 9. Unfortunately thes "Nexus Root Toolkit" app didn't help because my Nexus 9 was all stock, no root and the OEM unlock was disabled. The problem got me into a dead end. But I found a solution that helped me out and now my Nexus 9 is alive again. It's simple, but you need to follow the steps thoroughly.

Be advised that your data will be completely gone, but at least your tablet will live again.

  1. Ensure your tablet is fully charged and that you have 'adb' available (here's the official process, or a minimal installation)
  2. Download the OTA image for your device, mine was Nexus 9 Wifi so i picked the Nexus 9 "volantis"
  3. Start your Nexus and you'll see an image of an Android robot with a red exclamation mark (you may also see "No command").
  4. Press & hold the Power button. While holding Power, press the Volume up button once. Then release the Power button.
  5. You will then get into the Recovery Mode screen
  6. I executed a Wipe data/Factory reset, not sure if it's mandatory for this procedure, but I did, it's up to you.
  7. With the device connected with your computer choose the option: Apply update from ADB
  8. Execute the following command in the directory android_sdk_path/platform-tools:

    adb sideload path_to_the_ota_image_you_downloaded_on_step_2.zip
    
  9. Wait until it gets completed, restart the device and that is it!

Good luck!

It worked well for me on the first shot, I hope it helps you too.

1

I used Nexus Root Toolkit to restore stock ROM. It seems to be working now - the tablet booted, I see Welcome screen with a prompt to choose language.

Nexus Root Toolkit window

0

For those of you who had tried the above with no luck, here is a quick update about how I just unbricked my Nexus 9 device after a stock OTA update.

All of the above is correct but when I tried to sideload the latest version of the volantis.zip file I received an error message, something like

E: sigature verification failed E: ... Aborted

The solution was surprisingly simple

Sideload the very next version that the device currently has installed wich you can find on the second line of the recovery screen, in my case this was 6.0.1 (MOB30D)

I was nearly ready to give up but am currently updating to the latest android version after going back in and enabling USB debugging and the Bootloader (which were bother disabled before) then I managed to flash to 7.0.0 (NRD90M) with no problems or errors.

Next just a manual update from the device to the latest version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.