0

I am not able to get adb to recognize my device. Here is my setup:

  • USB debugging is enabled under Developer Options
  • Use USB Connection for File Transfer (Transfer Documents and media files to the connected device)
  • In device manager on Windows 10, under Portable Devices I see LG-M322. I have tried right-clicking on it -> update driver -> browse my computer for driver software -> C:\android-sdk\extras\google\usb_driver -> Next. It says the best drivers for your device are already installed. screenshot below enter image description here

But when I run adb devices I don't see my device:

C:\Users\me>adb devices -l
List of devices attached

I have tried killing the server many times as well as unplug the device and connect it again. I am able to transfer files to the device using windows explorer.

My phone is running Android version 7.0. Build number NRD90U. Software Version M322V10n.

How can I fix this please? I have tried similar posts and tried all the things they mention (the bullet points above).

  • On your device, while it is plugged in, can you tell me if you see a USB options notification? You should be able to select this notification and choose between some options like; File Transfer, PTP, Charge Only, ETC... – CzarMatt May 20 at 3:51
  • Yes that is bullet #2 in my question. I have selected File Transfer – morpheus May 20 at 4:21
  • If you want your device to show up when you type adb devices, you don't want "file transfer" selected. – CzarMatt May 20 at 4:26
0

changing the USB Mode to Photo Transfer worked

C:\Users\Downloads>adb devices
List of devices attached
LGM322c17168b6  device

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.