I have my mobile phone (Samsung Galaxy S2) running on ICS. Recently I activated Microsoft Exchnage ActiveSync to connect to my corporate email. It disabled all the security options like 'Pattern Unlock'. I hated it, and removed my microsoft active exchange account from the phone, but these options are still disabled. How do I get it enabled?

  • This is a guess, but give it a try. Settings, Security, Trusted credentials, User, and remove anything connected with your corporate e-mail. – Craig Stuntz Jun 18 '12 at 13:56
  • @CraigStuntz: I cleared all credentials from security settings..still doesn't work. – Asha Jun 19 '12 at 7:13

As a last ditch effort, you could try this:

  1. Use Titanium Backup to backup all your Apps + Data.
  2. Reset the phone to factory defaults.
  3. Restore all apps and data except for Activesync.

This will definitely fix your issues. Question is, "Is it worth the effort?"

  • Just an idea, have you tried doing a full reboot of the phone? I have been guilty of overlooking the simple solutions before. :) – ZnArK Jun 21 '12 at 14:39
  • Yup..rebooted at least thrice after changing various settings..I would really hate to reset to factory defaults..I will still play around with it sometime to see any other solution exists. – Asha Jun 22 '12 at 5:16
  • Reset the phone to factory defaults and restored..Nothing else worked. Thanks. – Asha Oct 9 '12 at 6:04

Had issue that "None", "Slide" and "Face unlock" were all greyed out.

Went to Security->Clear Credentials and all options became available.

  • 1
    Now, what to do when "Clear credentials" is greyed out. – Bob Stein Sep 4 '15 at 23:38

Okay, stab in the dark, but try this:

From the home screen, press Menu ->Settings->Location & Security->Select Device Administrators and look for something related to the Exchange account, most likely Corporate Sync. You should be able to change settings/disable it from there.

I've never used an Exchange account, so I can't test this :/ But it looks from reading around (here) that this may be your problem, otherwise it may be forced Exchange settings as described on this technet forum.

Let us know if this works, or points you in a new direction!

  • It says no device administrators in that section :( – Asha Jun 21 '12 at 9:04
  • rough :/ so i would assume those settings were set by the Exchange servers your company had set up, I would try connecting the account again and looking for some settings within that account that could change things back – jlehenbauer Jun 21 '12 at 12:11
  • Try connecting to the Exchange server first, then delete the setting in Settings > Location & Security > Select Device Administrators, once you delete the settings, disconnect from it... this is a long shot... :) – t0mm13b Jun 22 '12 at 20:29
  • Stab in the dark was right on target in my case. I am using Moto Razr ICS 4.04, though it deleted all exchange account contacts, calendar events and downloaded emails but I had already deleted my email account. My server policy requires a 6 digit pin with a change every month and the pin should not match last 12 pins...so losing all that info was still worth it. – user22686 Oct 21 '12 at 6:30

This is already answered, but here is an alternative that does not require you to remove whatever credential/configuration caused this in the the first place. After all, you needed the credential/configuration once and you will probably need it again.

This is probably caused by some configuration that installed a certificate on your device (such as a VPN profile, an exchange account, or secure wifi network). It could also could be caused by an app that has administrator privileges.

Here's the loophole: only the graphic interface for selecting these options is disabled. I was able to get around this using third-party apps. I used Tasker in combination with the free version of Secure Settings. In Tasker ... New Task -> Add Action -> Plugin -> Secure Settings -> Edit ... then choose your options. To make it take effect immediately, just press 'Run' when you get back to the Task Edit screen (looks like a 'play' button).

Please note:

  • This requires your phone to be rooted.
  • Encrypting your phone or SD card disables less secure lock options. I am unsure what effect the method described herein will have in those cases.
  • This method retains the configuration needed access the culprit account/service, but circumvents its security requirements. To use someone else words:

    There is a specific reason why an administrator configures such a policy, and I would recommend it to everyone. If your phone gets stolen nobody will be able to read your company's email, which is a secret. Lots of industrial accidents occurred because employees lost their mobile devices (laptops included) with sensitive data not protected enough.

    I suggest associating the Tasker task with a Tasker profile that is only activated in certain situations (for instance, when you are at home).


I recently ran into the same issue. After connecting to Exchange 2010 I was not able to reset back to a swipe unlock... even after removing the exchange account and clearing the credentials. Turns out that the policy of this Exchange connection required that you have high unlock security of a 6 character password including at least 1 digit and it encrypts your SD card (among other security features). I was not able to change back to the swipe unlock because the SD card was encrypted. At the time I had a 4 digit PIN (medium/high) as the security to unlock my phone, however the security was set to Password (high). Therefore I was able to get into my phone with the PIN, but not able to get to the options to decrypt the SD card.

To resolve the issue and decrypt the SD card I had to go through the Password security setup and create a password. After I created the password I was then able to get to the properties of "Encrypt external SD card" and uncheck the option to encrypt the SD card. Once the encryption was removed from the SD card I was able to change the unlock back to swipe.


Have you got VPN set up? - it requires it. I had VPN set up then decided i didn't it so after i removed the VPN (settings > other > VPN > long press > delete) the 'None' option for removing pin/password got enabled again


On a Galaxy S4 I had the exact same issue. Corporate Exchange policies grayed out all locks screen choices except password and pin. "Clear Credentials" was grayed out. After removing the Exchange account all options were still grayed out. I had to go through the Password Security setup wizard to create a device password. I then had to go into "Encrypt external SD card", even though I had no external SD card inserted, and turn that off. I could then, finally, change my screen lock types (I chose pattern lock). Took an hour of sleuthing, but this thread finally gave me the clues needed. Thanks all.

Not the answer you're looking for? Browse other questions tagged or ask your own question.