1

adb devices in the command shell gives me an empty list. I know this question is usually solved by: adb kill-server, adb start-server. However it still doesn't work. I had it working before because I put Cyanongenmod 10.2 on my HTC One X+.

I don't know if this is related, but because some apps couldn't be installed on my device through Google Play I tried to edit the build.prop file on my phone. I changed ro.blabla = GB --> NL (because I thought maybe changing country works). However since then I can't do anything after booting because it keeps repeating "Trebuchet stopped working". (I can still boot to FASTBOOT) So my plan is to edit this file on my PC, but for this I need ADB to work. Any suggestions?

Edit: Would be nice to let you know that I use Windows 7, but I also can use Ubuntu 12.04 in a virtual machine.

Edit2: If I'm in FASTBOOT my phone shows up in Windows device manger as Android USB Devices --- My HTC

Edit3: I can enter the standard Terminal Emulator and open the file with "su file build.prop", however it stays in Read-Only mode. Using "mount -o rw,remount /system" gives permission denied.

Edit4: I got into the settings menu and indeed I didn't have root right and not USB debugging on. Now I got adb working from my pc.

  • 2
    Did you turn USB debugging on again after installing Cyanogenmod? Does the phone think USB debugging is connected (there's a notification if it does)? – Dan Hulme Jun 18 '14 at 16:59
  • As @DanHulme said, Is USB Debugging enabled? Is your screen unlocked when you are trying to use ADB? – ZnewmaN Jun 18 '14 at 20:15
  • When I plug the usb cable in after unlocking the device it says: "Connected as a media device". I can only get into the menu where I can select: Media device (MTP) (currently checked) and Camera (PTP) (currently unchecked). – NumesSanguis Jun 18 '14 at 22:13
1

If you can't access developers options, do this first: Go to Settings -> About Phone -> click “Build Number” six times in a row. Now turn on USB debugging and give root permission to ADB.

Now ADB is working I followed the following tutorial: http://forum.xda-developers.com/showthread.php?t=1236732 and I think I put my edited file on my pc back on the phone. The problem now is that it keeps stuck at HTC screen logo. Seems there is no other option left then to restore an older version...

Edit: Guess it was better to use the original build.prop file from the cyanogenmod.zip instead of editing it. Now I have the same problem of ADB not finding my device, however this time without a booting system.

Edit 2: Through TWRP I restored an old backup, but I selected only to restore System and Boot, so I still got most of my Data :) Lesson to be learned: Before you do some changes to a system, no matter how trivial, backup everything first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.