A month ago, I've bought Samsung Galaxy A12 on Android 11, One UI 3.1. When I connect to PC, it doesn't work, no MTP, no ADB, only charging.

Tried different cables already. Also tried two cables, two different PC, and two OS; Linux and Windows 10. Tried to reboot, to enable and disable USB debugging, tried with USB configuration under developer settings and the *#0808# menu, nothing worked.

Can you help me?

  • Try different USB ports and if you have also a different phone. If switching the port and cable does not help but other phones work then most likely the USB port on the phone is broken (e.g. lose connection on some soldering points). Perform a factory reset and retry as last resort, if that doe snot help contact the vendor for a replacement/repair.
    – Robert
    Commented Feb 20, 2022 at 13:52
  • Tried two cable's, two different pc and two os; linux and windows 10.
    – user369241
    Commented Feb 20, 2022 at 15:04
  • For ADB, on Windows, a USB OEM driver needs to be installed. On Linux, plugdev and udev need to be set up.
    – Andrew T.
    Commented Feb 20, 2022 at 16:00

1 Answer 1


So,finally solved the problem, the phone type c port was broken. I've taken phone back to manufacturer to do an rma today.

You must log in to answer this question.