29

As I see an alternative keyboard may solve your issue, and this seems to be an acceptable solution, and you even mention something you cannot find -- hereby I proudly present: Hacker's Keyboard Checking its Guide, there's in fact a section suggesting such a feature: You can configure the gesture used for this in the keyboard's "Gesture and key actions" ...


23

Easiest way: add an extra letter at the end of the line. Select that letter. Hit enter. The letter will be replaced with a new line.


22

Vol Down + C is functionally equivalent to Ctrl + C.


19

press the shift key and see the change in the icon for the smiley. It changes to the enter key.


19

You can't disable the pop-up alone, but there are some other options:- You can disable the spell-checker completely. If your keyboard already provides all the spell-check functionality you need, then this might be a good option for you. In Language & input in the device settings, untick Spell checker. This will disable the pop-up and the red underlining ...


19

What you have to do is pair your external keyboard then Go to Settings -> Language & Input -> Physical Keyboard Then tap on your keyboard and a dialog for choosing the keyboard layout should appear. Choose the layouts you want (note that you have to select two or more to be able to switch) and then press back. Near the bottom of the dialog a label ...


17

Simply press the enter/return button in your key board. It is located at the right botton corner of your keyboard. In some cases, this button sends the SMS (or submit applications, in cases of forms in websites) If your device does that, simply hit enter/return button while holding the shift button or the upside arrow Hope this helps.


16

I what I will call a workaround for the present, as it is not a simple solution as allowing offensive words in voice typing, but it has the same final affect: Under Settings, choose Language & Input Choose Personal Dictionary Click the plus (+) button in the top right Enter the "offensive word" under the Phrase and Shortcut spaces Click the back button (...


11

Your current layout is called "Material Light". To change it, though there isn't a pure black version, go to Settings > Language and Input > Google Keyboard > Appearance and Layouts The dark material setting is called "Material Dark" and looks like this: I'm assuming you want material design as you are keeping it stock, but there are the old KitKat '...


11

you can find it on android setting keyboard & input > Virtual keyboard > Android keyboard setting Advanced > Emoji for physical keyboard disable it!


10

I fixed it! The trick was to clear the cache and data for Google Keyboard. Settings => Apps => ALL* => Google Keyboard => {Clear Data, Clear Cache} * Be sure to go to ALL instead of RUNNING. The instance under RUNNING will not give you the correct data clearing options.


9

You need to change the config.ini file in your .android directory. This file is found under the main hard drive directory. From there, open the avd file and you will see a list of virtual devices. Open the desired device and then open the config.ini in notepad. Then copy this text: "hw.keyboard = yes" (minus the quotes) and then save and close. The next time ...


9

Here are all the emoticons from Ice Cream Sandwich with typed string. And a couple of extra ones that are not mentioned above. From http://juxtaposedgraphix.blogspot.in/2012/09/android-40-ics-emoticons-ice-cream.html


9

This is supported in stock android. Settings -> Languages & Input -> Android Keyboard (Settings icon) -> Advanced settings -> Custom input styles -> Add style -> Set Language & Layout Then to activate this style, go back to the keyboard settings and go to the input languages and uncheck "use system language" then check the languages you want. :-)


9

I had the same issue, not with Cyanogen, but stock android in Nexus 5 phone. I solved the issue temporarily as follows : Go to Settings > Developer Options Change Animator Duration Scale to 0.5x (may be more. At first I set it in None, so it didn't work. Changing to 0.5x solved my problem. I didn't check other options like 1x etc). This method solved ...


9

Long press on the word when you type it and see it above keyboard. You will be given an option to delete it from learned words. Android 4.3


8

The stock keyboard in Jelly Bean (4.1 or 4.2) does not support multiple languages simultaneously. However, SwiftKey, a third party keyboard, supports advanced predictions with up to three languages simultaneously. SwiftKey Official Website SwiftKey on Google Play Note that SwiftKey is a paid app. You can find the non-trial versions of the application in ...


8

Yes you can do this. For this, I am assuming you are using the stock Google keyboard. Open Settings and tap on Language & Input. Tap on the settings icon next to Google Keyboard. Tap Input Languages at the top. Deselect "Use System Language" and then select any keyboard languages you wish to use. Now in the keyboard, the space bar will display the ...


8

See the Termux help page for how to input arrow keys using the VolumeUp button, VolumeDown for Ctrl and some additional shortcuts! Volume Up+W → Up arrow key


8

Keep in mind that GBoard provides a lot of language specific functionalities like automatic word correction or offline speech recognition. It seems like GBoard downloads these language specific data on first use. For example the directory com.google.android.inputmethod.latin/files/superpacks/delight seems to contain the offline language specific speech ...


7

I have a Nexus 4 from T-Mobile, the Google one, with Android 4.2.2. I've been noticing this same problem, and the fix I found was to go to Settings -> Language and Input -> Then press the settings icon next to the Google Keyboard (English, U.S.) option -> then deselect Block offensive words. I can now swype swear words, although often times it is not the ...


7

You need to install physical keyboard layouts. One of the best extensions to do that is this: RS - Hardware Keyboard Layouts It is free, and does nothing else. You use the standard settings page to select the hardware keyboard layout. (It is mystery why Google does not provide the layout files by default.)


7

I was testing ways to toggle the on-screen keyboard. In Android 4.2.2 on a Nexus 7 I had to go through the following steps to toggle the on-screen keyboard from the tablet while a Bluetooth keyboard is connected: To activate the "Choose Input Method" notification you need to have multiple keyboards available. On a stock Nexus 7 you can go into Settings then ...


7

I managed to remap the Caps Lock key to Ctrl using External Keyboard Helper Pro. It was really straightforward, just poke around in the settings and you'll find a way to create a custom mapping (Keycode 58 --> Left Control).


7

I had faced the same problem myself. System settings > device > accessibility > services. Something in there is set to On. Switch it to off and you will be OK. I had the same problem because I had an application set to on. Instant fix!


7

It worked for me to go into the Text Correction section of the Google Keyboard settings and then to Add-On Dictionaries. Emoji for English words said it was available so I installed it and then removed it. The auto correct of emoji icons has stopped for me since.


7

I was able to successfully type Hebrew with vowels on a Samsung using the steps I found on another forum: Since a few weeks ago it became possible to type vowels in the Gboard app—Google's own keyboard. I strongly recommend it. I switched from Samsung keyboard to it. To type the vowels, type the consonant first, and then hold down the letter ...


7

Remember that current keyboards are a bit different from keyboards from 10-15 years ago. Back then, their main purpose was just typing and writing. With time, emojis and gifs images became features also provided by keyboards, plus learning from your habits. If you have a file explorer that is able to read/view /data/data/com.google.android.inputmethod.latin/...


6

This answer is for those who built the emulator from source (i.e. Following instructions from source.android.com). You need to modify a property in the following file: external/qemu/android/avd/hardware-properties.ini In the following section of that file change the default value from no to yes: # Keyboard support (qwerty/azerty) name = hw....


6

The stock Android keyboard doesn't have ABC layout. However, there are some keyboard apps which have ABC layout. SlideIT English - ABC pack is an example. You can find some more if you search for "ABC keyboard" on Google Play.


Only top voted, non community-wiki answers of a minimum length are eligible